TUMBLEWEED Boot to cursor "i965_irq_handler" error

I have a dual-boot system between Windows 7 (which I have been trying to get upgraded to Windows 10 but it keeps failing), and openSUSE Tumbleweed running KDE. Some of the specifications are

Code:

ubuntu@ubuntu:~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:1a.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1d.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.3 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1d.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801IBM/IEM (ICH9M/ICH9M-E) 4 port SATA Controller [AHCI mode] (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
00:1f.6 Signal processing controller: Intel Corporation 82801I (ICH9 Family) Thermal Subsystem (rev 03)
02:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)


Currently when I log into openSUSE I am stuck at a blank screen with a cursor (but unable to type anything). I go into tty2 and can log in and have CLI capabilities.

I ran # dmesg and see an error message as the last entry

Code:

[  34.415296] [drm:i965_irq_handler [i915]] *ERROR* CPU pipe B FIFO underrun


the irq handler for i965/i915 leads me to believe it is something with the video drivers. The screen and such does work because I can log into Windows or a Linux Live USB and it works just fine.

When I reboot, I can go into Windows 7, but I just cannot get into openSUSE. I tried "zypper up" and am told there is nothing to do so i suspect I am up-to-date on everything.

I just tried looking into /var/log (I’m typing this from an Ubuntu Live USB) and the folder is empty. I can try from inside openSUSE if that will make any difference.

Thanks

p.s. I have just recently found https://forums.opensuse.org/showthre…ht=irq_handler and https://forums.opensuse.org/showthre…a-error-status which I am starting to go through now, but they reference nvidia graphics and mine is Intel so we’ll see…

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.