openSUSE 13.2 Lenovo T550 keyboard woes

I’ve just been given a new Lenovo T550 laptop for work, and my boss asked me to install openSUSE with KDE, neither of which have I used in quite some time after working in a RHEL shop for a few years.

Generally I am very happy with KDE & openSUSE, but I have had a few issues which I am struggling with and haven’t found solutions for all of them, these are mainly down to the laptop make & model I am pretty sure.

Keyboard:

  • The most important first step for me was switching the Fn & Ctrl keys in the BIOS, as it’s so annoying when you press Fn instead of Ctrl every bleedin’ time!
  • The Fn keys on F4 – F12 don’t work when pressed, the F1-3 keys work (volume), so the Fn key is working, but the other 9 don’t do anything – when I try and bind any of these Fn keys in Global shortcuts they appear to come up as "Wake up"
  • There are also 4 keys in the top right of the keyboard, Calculator (working), lock (not working), web (working – takes me to a homepage in FF), folder (not working)
  • I have also been given a logitech wireless k/b which has similar issues with Fn keys and special keys, but I’m hoping if I can figure out how to fix the issues I have described I can also figure out the other issues (I guess I may have to set up 2 k/b profiles and switch between them – although it would be nice if KDE knew which one I was using and used the right mapping for each!)
  • The windows key on the keyboard didn’t bring up the Application launch menu, to fix this I had to install ksuperkey – I’m just leaving this here for any other kde n00b who see’s this post

I tried binding the lock key to "Lock screen" in Global Shortcuts > khotkeys, this key appears to be an alias of Meta + L, now when I press either Meta +L or the lock button, a prompt appears entitled "Input action: Comment KDE Daemon" which states "No service configured". I would like both of these to work, but I am at a loss as to what to do here. Strangely Ctrl+Alt+L still works (although I forget and have left my screen unlocked before without realising).

I was advised on the other post I saw that I needed to change my keyboard type, I looked in System settings > Input devices, and I tried all of the Lenovo keyboards I saw in there (applying between changes) but the Fn keys still didn’t work correctly. But then I also don’t see "Asus Keyboard" in the list, which that poster states he has to use for his laptop. So I guess I must be missing something… Is there another package I need to install, or am I looking in the wrong area? Or do I need to reboot between changes?

Source: forum

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.